sys-fs/fuse-zip: Fixing HOMEPAGE move due to code.google.com shutdown
[gentoo.git] / sys-fs / fuse-zip / fuse-zip-0.3.0.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit toolchain-funcs eutils
8
9 DESCRIPTION="FUSE file system to navigate, extract, create and modify ZIP archives"
10 HOMEPAGE="https://bitbucket.org/agalanin/fuse-zip"
11 SRC_URI="https://fuse-zip.googlecode.com/files/${P}.tar.gz"
12
13 LICENSE="LGPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND="dev-libs/libzip
19         sys-fs/fuse"
20 RDEPEND="${DEPEND}"
21
22 RESTRICT="test"
23
24 src_prepare() {
25         # Fix strip than installing fuse-zip
26         sed -i -e 's/install -m 755 -s/install -m 755/' Makefile || die "sed failed"
27         # fix broken makefile
28         epatch "${FILESDIR}"/"${PN}"-0.2.13-as-needed.patch
29         #enable parallel build
30         sed -i -e "s:make :\$\(MAKE\) :" Makefile || die "sed failed"
31 }
32
33 src_compile() {
34         emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS} ${LDFLAGS}"
35 }
36
37 src_install() {
38         emake INSTALLPREFIX="${D}"/usr install
39 }