dev-python/xmlschema: arm64 stable (bug #723996)
[gentoo.git] / sys-fs / e4rat / e4rat-0.2.4_pre20141201-r1.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit cmake-utils linux-info readme.gentoo-r1
6
7 DESCRIPTION="Toolset to accelerate the boot process and application startup"
8 HOMEPAGE="http://e4rat.sourceforge.net/"
9 #SRC_URI="mirror://sourceforge/${PN}/${P/-/_}_src.tar.gz"
10 SRC_URI="https://dev.gentoo.org/~pacho/${PN}/${PN}-0.2.4_pre20141201.tar.xz"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE=""
16
17 RDEPEND="
18         dev-lang/perl:=
19         >=dev-libs/boost-1.42:=
20         sys-fs/e2fsprogs
21         sys-process/audit[static-libs(+)]
22         sys-process/lsof
23 "
24 DEPEND="${DEPEND}"
25
26 CONFIG_CHECK="~AUDITSYSCALL"
27
28 PATCHES=(
29         "${FILESDIR}"/${PN}-0.2.2-shared-build.patch
30         "${FILESDIR}"/${PN}-0.2.2-libdir.patch
31         "${FILESDIR}"/${PN}-0.2.4-sysmacros.patch #580534
32         "${FILESDIR}"/${PN}-0.2.4-gcc6.patch #594046
33         "${FILESDIR}"/${PN}-0.2.4-strdup.patch
34 )
35
36 pkg_setup() {
37         check_extra_config
38         DOC_CONTENTS="
39                 To launch systemd from e4rat you simply need to edit /etc/e4rat.conf
40                 and set:\n
41                 ; path to init process binary (DEFAULT: /sbin/init)\n
42                 init /usr/lib/systemd/systemd"
43 }
44
45 src_install() {
46         cmake-utils_src_install
47         # relocate binaries to /sbin. If someone knows of a better way to do it
48         # please do tell me
49         dodir sbin
50         find "${D}"/usr/sbin -type f -exec mv {} "${D}"/sbin/. \; \
51                 || die
52
53         readme.gentoo_create_doc
54 }
55
56 pkg_postinst() {
57         readme.gentoo_print_elog
58         if has_version sys-apps/preload; then
59                 elog "It appears you have sys-apps/preload installed. This may"
60                 elog "has negative effects on ${PN}. You may want to disable preload"
61                 elog "when using ${PN}."
62         fi
63 }