sys-fs/btrfs-progs: arm stable, bug #577016
[gentoo.git] / sys-fs / btrfs-progs / btrfs-progs-3.14.2.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit eutils multilib toolchain-funcs
8
9 libbtrfs_soname=0
10
11 if [[ ${PV} != 9999 ]]; then
12         MY_PV=v${PV}
13         KEYWORDS="~alpha amd64 arm ~ia64 ~mips ppc ppc64 ~sparc x86"
14         SRC_URI="https://www.kernel.org/pub/linux/kernel/people/mason/${PN}/${PN}-${MY_PV}.tar.xz"
15         S="${WORKDIR}"/${PN}-${MY_PV}
16 else
17         inherit git-2
18         EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/mason/btrfs-progs.git
19                 https://git.kernel.org/pub/scm/linux/kernel/git/mason/btrfs-progs.git"
20 fi
21
22 DESCRIPTION="Btrfs filesystem utilities"
23 HOMEPAGE="https://btrfs.wiki.kernel.org"
24
25 LICENSE="GPL-2"
26 SLOT="0/${libbtrfs_soname}"
27 IUSE=""
28
29 RDEPEND="
30         dev-libs/lzo:2=
31         sys-libs/zlib:0=
32         sys-fs/e2fsprogs:0=
33 "
34 DEPEND="${RDEPEND}
35         sys-apps/acl
36         app-text/asciidoc
37         app-text/docbook-xml-dtd:4.5
38         app-text/xmlto
39 "
40
41 src_prepare() {
42         epatch "${FILESDIR}/${PN}-3.14.2-install-man.patch"
43         epatch_user
44 }
45
46 src_compile() {
47         emake \
48                 AR="$(tc-getAR)" \
49                 CC="$(tc-getCC)" \
50                 CFLAGS="${CFLAGS}" \
51                 LDFLAGS="${LDFLAGS}" \
52                 BUILD_VERBOSE=1
53 }
54
55 src_install() {
56         emake install \
57                 DESTDIR="${D}" \
58                 prefix=/usr \
59                 bindir=/sbin \
60                 libdir=/usr/$(get_libdir) \
61                 mandir=/usr/share/man
62 }