dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / sys-firmware / iwl8000-ucode / iwl8000-ucode-16.242414.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit linux-info
7
8 MY_P="iwlwifi-${P#iwl}"
9
10 DESCRIPTION="Firmware for Intel (R) Wireless 8260 and 4165"
11 HOMEPAGE="https://wireless.kernel.org/en/users/Drivers/iwlwifi"
12 SRC_URI="https://wireless.wiki.kernel.org/_media/en/users/drivers/${MY_P}.tgz"
13
14 LICENSE="ipw3945"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17
18 DEPEND=""
19 RDEPEND="
20         !sys-kernel/linux-firmware[-savedconfig]
21 "
22
23 CONFIG_CHECK="~IWLMVM"
24 ERROR_IWLMVM="CONFIG_IWLMVM is required to be enabled in /usr/src/linux/.config for the kernel to be able to load the ${DEV_N} firmware"
25
26 S="${WORKDIR}/${MY_P}"
27
28 pkg_pretend() {
29         if kernel_is lt 4 3 0; then
30                 eerror "Your kernel version is ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}."
31                 eerror "This microcode image requires a kernel >= 4.3.0."
32         fi
33 }
34
35 src_install() {
36         insinto /lib/firmware
37         doins iwlwifi-8000C-16.ucode
38         dodoc README*
39 }