dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / sys-firmware / iwl3160-7260-bt-ucode / iwl3160-7260-bt-ucode-37.8.10_p2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit linux-info
6
7 DESCRIPTION="Firmware for Intel (R) Wireless 3160, 7260, 7265 Bluetooth"
8 HOMEPAGE="https://wireless.kernel.org/en/users/Drivers/iwlwifi"
9 SRC_URI="mirror://gentoo/${P}.tgz"
10
11 LICENSE="ipw3945"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND=""
17 RDEPEND="!sys-kernel/linux-firmware[-savedconfig]"
18
19 S="${WORKDIR}"
20
21 CONFIG_CHECK="~IWLMVM"
22 ERROR_IWLMVM="CONFIG_IWLMVM is required to be enabled in /usr/src/linux/.config for the kernel to be able to load the Intel (R) Wireless 3160, 7260, 7265 firmware"
23
24 pkg_pretend() {
25         if kernel_is lt 3 10 0; then
26                 ewarn "Your kernel version is ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}."
27                 ewarn "This microcode image requires a kernel >= 3.10.0."
28         fi
29 }
30
31 src_install() {
32         insinto /lib/firmware
33         doins -r "${S}/intel"
34 }