sys-devel/remake: Version bump
[gentoo.git] / sys-devel / remake / remake-4.2.1.1.4.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MY_P="${PN}-${PV:0:5}+dbg-${PV:6}"
7
8 DESCRIPTION="patched version of GNU make with improved error reporting, tracing and debugging"
9 HOMEPAGE="http://bashdb.sourceforge.net/remake/"
10 SRC_URI="mirror://sourceforge/bashdb/${MY_P}.tar.bz2"
11
12 LICENSE="GPL-1"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
15 IUSE="guile readline"
16
17 RDEPEND="readline? ( sys-libs/readline:0= )
18         guile? ( >=dev-scheme/guile-1.8:= )"
19 DEPEND="${RDEPEND}"
20
21 S=${WORKDIR}/${MY_P}
22
23 PATCHES=(
24         "${FILESDIR}/make-4.2.1-glob-v2.patch"
25 )
26
27 src_configure() {
28         use readline || export vl_cv_lib_readline=no
29         econf $(use_with guile)
30 }
31
32 src_install() {
33         default
34         # delete files GNU make owns and remake doesn't care about.
35         rm -r "${ED}"/usr/include || die
36 }