sci-geosciences/gpsbabel: EAPI-7 bump, use desktop.eclass
[gentoo.git] / sys-devel / kgcc64 / kgcc64-4.8.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 case ${CHOST} in
7         hppa*)    CTARGET=hppa64-${CHOST#*-};;
8         mips*)    CTARGET=${CHOST/mips/mips64};;
9         powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
10         s390*)    CTARGET=${CHOST/s390/s390x};;
11         sparc*)   CTARGET=${CHOST/sparc/sparc64};;
12         i?86*)    CTARGET=x86_64-${CHOST#*-};;
13 esac
14 export CTARGET
15 TOOLCHAIN_ALLOWED_LANGS="c"
16 GCC_TARGET_NO_MULTILIB=true
17
18 PATCH_VER="1.3"
19
20 inherit eutils toolchain
21
22 DESCRIPTION="64bit kernel compiler"
23
24 # Works on mips and sparc; all other archs, refer to bug #228115
25 KEYWORDS="hppa"
26
27 RDEPEND=">=dev-libs/gmp-4.3.2
28         >=dev-libs/mpfr-2.4.2
29         >=dev-libs/mpc-0.8.1
30         >=sys-devel/gcc-config-1.4"
31 # unlike every other target, hppa has not unified the 32/64 bit
32 # ports in binutils yet
33 DEPEND="${RDEPEND}
34         hppa? ( sys-devel/binutils-hppa64 )
35         >=sys-apps/texinfo-4.8
36         >=sys-devel/bison-1.875"
37
38 pkg_postinst() {
39         toolchain_pkg_postinst
40
41         cd "${ROOT}"/usr/bin
42         local x
43         for x in gcc cpp ; do
44                 cat <<-EOF >${CTARGET%%-*}-linux-${x}
45                 #!/bin/sh
46                 exec ${CTARGET}-${x} "\$@"
47                 EOF
48                 chmod a+rx ${CTARGET%%-*}-linux-${x}
49         done
50 }