kde-frameworks/prison: metadata whitespace
[gentoo.git] / sys-devel / kgcc64 / kgcc64-4.3.5.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5
6 case ${CHOST} in
7         hppa*)    CTARGET=hppa64-${CHOST#*-};;
8         mips*)    CTARGET=${CHOST/mips/mips64};;
9         powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
10         s390*)    CTARGET=${CHOST/s390/s390x};;
11         sparc*)   CTARGET=${CHOST/sparc/sparc64};;
12         i?86*)    CTARGET=x86_64-${CHOST#*-};;
13 esac
14 export CTARGET
15 TOOLCHAIN_ALLOWED_LANGS="c"
16 GCC_TARGET_NO_MULTILIB=true
17
18 PATCH_VER="1.1"
19 GCC_FILESDIR=${FILESDIR/${PN}/gcc}
20
21 inherit eutils toolchain
22
23 DESCRIPTION="64bit kernel compiler"
24
25 # Works on mips and sparc; all other archs, refer to bug #228115
26 KEYWORDS="-hppa ~mips ~sparc"
27
28 # unlike every other target, hppa has not unified the 32/64 bit
29 # ports in binutils yet
30 DEPEND="hppa? ( sys-devel/binutils-hppa64 )
31         !sys-devel/gcc-hppa64
32         !sys-devel/gcc-mips64
33         !sys-devel/gcc-powerpc64
34         !sys-devel/gcc-sparc64"
35
36 pkg_postinst() {
37         toolchain_pkg_postinst
38
39         cd "${ROOT}"/usr/bin
40         local x
41         for x in gcc cpp ; do
42                 cat <<-EOF >${CTARGET%%-*}-linux-${x}
43                 #!/bin/sh
44                 exec ${CTARGET}-${x} "\$@"
45                 EOF
46                 chmod a+rx ${CTARGET%%-*}-linux-${x}
47         done
48 }