Unify quoting in metadata.xml files for machine processing
[gentoo.git] / sys-devel / gcc / gcc-5.1.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="4"
6
7 PATCH_VER="1.2"
8 UCLIBC_VER="1.0"
9
10 # Hardened gcc 4 stuff
11 PIE_VER="0.6.4"
12 SPECS_VER="0.2.0"
13 SPECS_GCC_VER="4.4.3"
14 # arch/libc configurations known to be stable with {PIE,SSP}-by-default
15 PIE_GLIBC_STABLE="x86 amd64 mips ppc ppc64 arm ia64"
16 PIE_UCLIBC_STABLE="x86 arm amd64 mips ppc ppc64"
17 SSP_STABLE="amd64 x86 mips ppc ppc64 arm"
18 # uclibc need tls and nptl support for SSP support
19 # uclibc need to be >= 0.9.33
20 SSP_UCLIBC_STABLE="x86 amd64 mips ppc ppc64 arm"
21 #end Hardened stuff
22
23 inherit toolchain
24
25 #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
26
27 RDEPEND=""
28 DEPEND="${RDEPEND}
29         elibc_glibc? ( >=sys-libs/glibc-2.8 )
30         >=${CATEGORY}/binutils-2.20"
31
32 if [[ ${CATEGORY} != cross-* ]] ; then
33         PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
34 fi
35
36 src_prepare() {
37         if has_version '<sys-libs/glibc-2.12' ; then
38                 ewarn "Your host glibc is too old; disabling automatic fortify."
39                 ewarn "Please rebuild gcc after upgrading to >=glibc-2.12 #362315"
40                 EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
41         fi
42         is_crosscompile && EPATCH_EXCLUDE+=" 05_all_gcc-spec-env.patch"
43
44         toolchain_src_prepare
45 }