Unify quoting in metadata.xml files for machine processing
[gentoo.git] / sys-devel / gcc / gcc-4.3.6-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 PATCH_VER="1.2"
8 UCLIBC_VER="1.0"
9
10 inherit toolchain
11
12 KEYWORDS="alpha amd64 arm -hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd"
13
14 RDEPEND=""
15 DEPEND="${RDEPEND}
16         ppc? ( >=${CATEGORY}/binutils-2.17 )
17         ppc64? ( >=${CATEGORY}/binutils-2.17 )
18         >=${CATEGORY}/binutils-2.15.94"
19 if [[ ${CATEGORY} != cross-* ]] ; then
20         PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
21 fi
22
23 src_prepare() {
24         toolchain_src_prepare
25
26         use vanilla && return 0
27
28         sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
29 }