sys-devel/gcc: switch gcc master to 11.0.0 version
[gentoo.git] / sys-devel / dwz / dwz-0.12-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 FPKG_HASH="1624afa75b94633e03c6e1bb952fb348"
9
10 DESCRIPTION="DWARF optimization and duplicate removal tool"
11 HOMEPAGE="https://sourceware.org/git/?p=dwz.git;a=summary"
12 SRC_URI="https://src.fedoraproject.org/repo/pkgs/dwz/${P}.tar.bz2/${FPKG_HASH}/${P}.tar.bz2"
13
14 LICENSE="GPL-2+ GPL-3+"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE=""
18
19 DEPEND="dev-libs/elfutils"
20 RDEPEND="${DEPEND}"
21 BDEPEND=""
22
23 src_prepare() {
24         default
25         sed -i \
26                 -e '/^CFLAGS/d' \
27                 Makefile || die "sed failed"
28         tc-export CC
29 }