Use https by default
[gentoo.git] / sys-devel / crossdev / crossdev-20120228.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="4"
6
7 if [[ ${PV} == "99999999" ]] ; then
8         EGIT_REPO_URI="git://anongit.gentoo.org/proj/crossdev.git"
9         inherit git-2
10         SRC_URI=""
11         #KEYWORDS=""
12 else
13         SRC_URI="mirror://gentoo/${P}.tar.xz
14                 https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
15         KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
16 fi
17
18 DESCRIPTION="Gentoo Cross-toolchain generator"
19 HOMEPAGE="https://www.gentoo.org/"
20
21 LICENSE="GPL-2"
22 SLOT="0"
23 IUSE=""
24
25 RDEPEND=">=sys-apps/portage-2.1
26         app-shells/bash
27         !sys-devel/crossdev-wrappers"
28 DEPEND="app-arch/xz-utils"
29
30 src_install() {
31         default
32         if [[ "${PV}" == "99999999" ]] ; then
33                 sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
34         fi
35 }