sys-devel/clang-runtime: Bump to 9.0.1_rc1
[gentoo.git] / sys-devel / clang-runtime / clang-runtime-9.0.1_rc1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit multilib-build
7
8 DESCRIPTION="Meta-ebuild for clang runtime libraries"
9 HOMEPAGE="https://clang.llvm.org/"
10 SRC_URI=""
11
12 LICENSE="metapackage"
13 SLOT="$(ver_cut 1-3)"
14 KEYWORDS=""
15 IUSE="+compiler-rt libcxx openmp +sanitize"
16 REQUIRED_USE="sanitize? ( compiler-rt )"
17 PROPERTIES="live"
18
19 RDEPEND="
20         compiler-rt? (
21                 ~sys-libs/compiler-rt-${PV}:${SLOT}
22                 sanitize? ( ~sys-libs/compiler-rt-sanitizers-${PV}:${SLOT} )
23         )
24         libcxx? ( >=sys-libs/libcxx-${PV}[${MULTILIB_USEDEP}] )
25         openmp? ( >=sys-libs/libomp-${PV}[${MULTILIB_USEDEP}] )"