sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / sys-devel / boost-m4 / boost-m4-0.4_p20160328.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Another set of autoconf macros for compiling against boost"
7 HOMEPAGE="https://github.com/tsuna/boost.m4"
8 SRC_URI="https://dev.gentoo.org/~soap/distfiles/${P}.tar.gz"
9
10 LICENSE="GPL-3"
11 SLOT="0"
12 KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
13 IUSE=""
14 S="${WORKDIR}/boost.m4-1489691f65aecb593e33abc3e56ac482dd67da7b"
15
16 # boost.m4 has a buildsystem, but the distributer didn't use make dist
17 # so we'd have to eautoreconf to use it. Also, its ./configure script
18 # DEPENDs on boost. For installing one file, bootstrapping the
19 # buildsystem isn't worth it.
20 src_configure() { :; }
21
22 src_compile() { :; }
23
24 src_install() {
25         insinto /usr/share/aclocal
26         doins build-aux/boost.m4
27
28         dodoc AUTHORS NEWS README THANKS
29 }