dev-util/rebar: version bump to 2.5.1
[gentoo.git] / sys-devel / autoconf / autoconf-2.65-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6
7 inherit eutils
8
9 DESCRIPTION="Used to create autoconfiguration files"
10 HOMEPAGE="https://www.gnu.org/software/autoconf/autoconf.html"
11 SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
12
13 LICENSE="GPL-3"
14 SLOT="${PV}"
15 KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
16 IUSE=""
17
18 DEPEND=">=sys-devel/m4-1.4.6
19         dev-lang/perl"
20 RDEPEND="${DEPEND}
21         !~sys-devel/${P}:0
22         >=sys-devel/autoconf-wrapper-13"
23
24 PATCHES=(
25         "${FILESDIR}"/${P}-AC_TYPE_INT_T.patch #324649
26 )
27
28 if [[ -z ${__EBLITS__} && -n ${FILESDIR} ]] ; then
29         source "${FILESDIR}"/eblits/main.eblit || die
30 fi
31 src_prepare()   { eblit-run src_prepare   ; }
32 src_configure() { eblit-run src_configure ; }
33 src_install()   { eblit-run src_install   ; }