Revert DOCTYPE SYSTEM https changes in metadata.xml
[gentoo.git] / sys-cluster / libcman / libcman-3.2.0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6
7 inherit linux-info multilib toolchain-funcs versionator
8
9 CLUSTER_RELEASE="${PV}"
10 MY_P="cluster-${CLUSTER_RELEASE}"
11
12 MAJ_PV="$(get_major_version)"
13 MIN_PV="$(get_version_component_range 2-3)"
14
15 DESCRIPTION="Cluster Manager Library"
16 HOMEPAGE="https://fedorahosted.org/cluster/wiki/HomePage"
17 SRC_URI="https://fedorahosted.org/releases/c/l/cluster/${MY_P}.tar.gz"
18
19 LICENSE="LGPL-2.1"
20 SLOT="0"
21 KEYWORDS="~amd64 ~hppa ~x86"
22 IUSE="static-libs"
23
24 DEPEND=">=sys-kernel/linux-headers-2.6.24"
25 RDEPEND="!sys-cluster/cman-lib"
26
27 S="${WORKDIR}/${MY_P}/cman/lib"
28
29 src_configure() {
30         cd "${WORKDIR}/${MY_P}"
31         ./configure \
32                 --cc=$(tc-getCC) \
33                 --cflags="-Wall" \
34                 --libdir=/usr/$(get_libdir) \
35                 --disable_kernel_check \
36                 --kernel_src=${KERNEL_DIR} \
37                 --somajor="$MAJ_PV" \
38                 --sominor="$MIN_PV" \
39                 --cmanlibdir=/usr/$(get_libdir) \
40                 --cmanincdir=/usr/include \
41                 || die "configure failed"
42 }
43
44 src_install() {
45         default
46         use static-libs || rm -f "${D}"/usr/lib*/*.a
47 }