*/*: Drop stable alpha keywords
[gentoo.git] / sys-boot / woeusb / woeusb-3.3.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 WX_GTK_VER="3.0-gtk3"
6
7 inherit autotools wxwidgets
8
9 DESCRIPTION="Creates windows installer on usb media from an iso image"
10 HOMEPAGE="https://github.com/slacka/WoeUSB"
11 SRC_URI="https://github.com/slacka/WoeUSB/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE="minimal"
17
18 RDEPEND="
19         sys-apps/util-linux
20         sys-block/parted
21         sys-fs/dosfstools
22         sys-fs/ntfs3g
23         sys-boot/grub:2[grub_platforms_pc]
24         !minimal? ( x11-libs/wxGTK:${WX_GTK_VER}[X] )
25 "
26 DEPEND="${RDEPEND}"
27
28 S="${WORKDIR}/WoeUSB-${PV}"
29
30 src_prepare() {
31         default
32         find . -type f -print0 | xargs -0 sed -i "s/@@WOEUSB_VERSION@@/${PV}/" || die
33         if ! use minimal; then
34                 setup-wxwidgets
35                 eautoreconf
36         fi
37 }
38
39 src_configure() {
40         ! use minimal && default
41 }
42
43 src_compile() {
44         ! use minimal && default
45 }
46
47 src_test() {
48         ! use minimal && default
49 }
50
51 src_install() {
52         if use minimal; then
53                 dosbin src/woeusb
54                 einstalldocs
55         else
56                 default
57         fi
58 }