sys-boot/colo: Use EAPI=6 and fix minor gcc build issue
[gentoo.git] / sys-boot / sgibootcd / sgibootcd-0.12.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5 inherit eutils toolchain-funcs
6
7 DESCRIPTION="Creates burnable CD images for SGI LiveCDs"
8 HOMEPAGE="ftp://ftp.linux-mips.org/pub/linux/mips/people/skylark/"
9 SRC_URI="ftp://ftp.linux-mips.org/pub/linux/mips/people/skylark/${P}.tar.bz2"
10 LICENSE="all-rights-reserved"
11 SLOT="0"
12 KEYWORDS="-* ~mips"
13 IUSE=""
14 RDEPEND=""
15 DEPEND=""
16 RESTRICT=""
17
18 src_compile() {
19         local mycc="$(tc-getCC) ${CFLAGS}"
20
21         [ -f "${S}/sgibootcd" ] && rm -f "${S}"/sgibootcd
22         einfo "${mycc} sgibootcd.c -o sgibootcd"
23         ${mycc} sgibootcd.c -o sgibootcd
24 }
25
26 src_install() {
27         dobin "${S}"/sgibootcd
28 }