Use https by default
[gentoo.git] / sys-boot / plymouth-openrc-plugin / plymouth-openrc-plugin-0.1.2.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6
7 inherit multilib
8
9 DESCRIPTION="Plymouth plugin for OpenRC"
10 HOMEPAGE="https://github.com/aidecoe/plymouth-openrc-plugin"
11 SRC_URI="
12 https://dev.gentoo.org/~aidecoe/distfiles/${CATEGORY}/${PN}/${P}.tar.bz2"
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
16 IUSE=""
17 DEPEND=">=sys-apps/openrc-0.8.2-r1"
18 RDEPEND="${DEPEND}
19         >=sys-boot/plymouth-0.8.3-r5
20         "
21
22 src_install() {
23         insinto /$(get_libdir)/rc/plugins
24         doins plymouth.so
25 }
26
27 pkg_postinst() {
28         ewarn "You need to disable 'interactive' feature in /etc/rc.conf to make"
29         ewarn "Plymouth work properly with OpenRC init system."
30
31         if [[ ! -d /run ]]; then
32                 eerror "/run doesn't exist!  You need to create this directory."
33                 echo
34                 einfo "If you'd like to know more about purpose of /run, please read:"
35                 einfo "  https://lwn.net/Articles/436012/"
36         fi
37
38         if has_version sys-apps/systemd; then
39                 eerror "sys-apps/systemd is installed, please uninstall this package if you"
40                 eerror "are booting with systemd"
41         fi
42 }