dev-cpp/waylandpp: 0.2.3 version bump
[gentoo.git] / sys-boot / efibootmgr / efibootmgr-15.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="User-space application to modify the EFI boot manager"
9 HOMEPAGE="https://github.com/rhinstaller/efibootmgr"
10 SRC_URI="https://github.com/rhinstaller/efibootmgr/releases/download/${PV}/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~arm64 ia64 x86"
15 IUSE=""
16
17 RDEPEND="sys-apps/pciutils
18         >=sys-libs/efivar-25:="
19 DEPEND="${RDEPEND}"
20
21 src_prepare() {
22         default
23         sed -i -e s/-Werror// Make.defaults || die
24 }
25
26 src_configure() {
27         tc-export CC
28         export EFIDIR="Gentoo"
29 }