sys-boot/palo: Fix compiling ipl with GCC 10
[gentoo.git] / sys-boot / bootcreator / bootcreator-1.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Simple generator for Forth based BootMenu scripts for Pegasos machines"
7 HOMEPAGE="http://tbs-software.com/morgoth/projects.html"
8 SRC_URI="http://tbs-software.com/morgoth/files/bootcreator-src.tar.gz"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="-* ppc"
13 IUSE=""
14
15 DEPEND=""
16
17 S=${WORKDIR}
18
19 src_compile() {
20         emake all
21 }
22
23 src_install() {
24         dosbin src/bootcreator
25         dodoc doc/README
26
27         insinto /etc
28         newins examples/example.bc bootmenu.example
29 }