sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / sys-block / whdd / whdd-3.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Diagnostic and recovery tool for block devices"
7 HOMEPAGE="https://whdd.github.io"
8
9 inherit toolchain-funcs
10
11 if [[ ${PV} == 9999 ]]
12 then
13         EGIT_REPO_URI="https://github.com/${PN}/${PN}"
14         inherit git-r3
15 else
16         SRC_URI="https://github.com/${PN}/${PN}/tarball/${PV} -> ${P}.tar.gz"
17         KEYWORDS="~amd64 ~x86"
18         inherit vcs-snapshot
19 fi
20
21 LICENSE="GPL-3"
22 SLOT="0"
23 IUSE=""
24
25 DEPEND="
26         dev-util/dialog:=
27         sys-libs/ncurses:0=[unicode]"
28 RDEPEND="${DEPEND}
29         sys-apps/smartmontools"
30
31 src_compile() {
32         tc-export CC
33         default
34 }