sys-block/thin-provisioning-tools: keyword 0.8.5 for ~riscv
[gentoo.git] / sys-block / spindown / spindown-0.4.0-r5.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Spindown is a daemon that can spin down idle disks"
7 HOMEPAGE="https://code.google.com/p/spindown"
8 SRC_URI="https://spindown.googlecode.com/files/${P}.tar.gz"
9
10 LICENSE="GPL-3"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE=""
14
15 DEPEND=""
16 RDEPEND="${DEPEND}
17         sys-apps/sg3_utils"
18
19 src_prepare() {
20         eapply "${FILESDIR}"/${P}-CFLAGS-LDFLAGS.patch
21         eapply_user
22 }
23
24 src_compile() {
25         emake
26 }
27
28 src_install() {
29         insinto /etc
30         newins spindown.conf.example spindown.conf
31         newinitd "${FILESDIR}"/spindownd.initd-r1 spindownd
32         newconfd "${FILESDIR}"/spindownd.confd-r1 spindownd
33         dosbin spindownd
34         dodoc CHANGELOG README TODO spindown.conf.example
35 }
36
37 pkg_postinst() {
38         elog "Before starting spindownd the first time"
39         elog "you should modify /etc/spindown.conf"
40         elog
41         elog "To start spindownd by default"
42         elog "you should add it to the default runlevel:"
43         elog "  rc-update add spindownd default"
44 }