dev-ruby/actioncable: add rails 5.1.1
[gentoo.git] / sys-block / seekwatcher / seekwatcher-0.12_p20091015-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python2_7 )
6
7 inherit eutils distutils-r1
8
9 DESCRIPTION="generates graphs from blktrace to help visualize IO patterns and performance"
10 HOMEPAGE="http://oss.oracle.com/~mason/seekwatcher/"
11 #SRC_URI="http://oss.oracle.com/~mason/seekwatcher/${P}.tar.bz2"
12 SRC_URI="https://dev.gentoo.org/~slyfox/${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE=""
18
19 DEPEND="dev-python/pyrex"
20 RDEPEND="
21         dev-python/matplotlib[${PYTHON_USEDEP}]
22         dev-python/numpy[${PYTHON_USEDEP}]
23         >=sys-block/blktrace-0.0.20070730162628
24 "
25
26 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
27
28 S=${WORKDIR}/${PN}-b392aeaf693b # hg snapshot
29
30 PATCHES=("${FILESDIR}"/${P}-dash-fix.patch)