app-misc/graphlcd-base: updated metadata.xml description
[gentoo.git] / sys-block / sas3ircu / sas3ircu-5.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit mount-boot
6
7 DESCRIPTION="LSI MPT-SAS3 controller management tool"
8 HOMEPAGE="http://www.lsi.com/support/Pages/download-results.aspx?component=Storage+Component&productfamily=Host+Bus+Adapters&productcode=0&assettype=Miscellaneous&productname=&keyword=SAS3IRCU"
9 LICENSE="LSI"
10 SLOT="0"
11 KEYWORDS="-* ~amd64 ~ppc64 ~x86 ~sparc-solaris ~x64-solaris ~x86-solaris"
12 IUSE="efi doc"
13 RESTRICT="strip fetch mirror"
14 DEPEND=""
15 RDEPEND=""
16 QA_PREBUILT="opt/lsi/sas3ircu boot/efi/sas3ircu.efi"
17
18 MY_PN=SAS3IRCU
19 MY_P="${MY_PN}_P${PV}"
20
21 DISTFILE_BIN=${MY_P}.zip
22 DISTFILE_DOC=SAS3IRCU_UG.pdf
23
24 SRC_URI="
25 http://www.lsi.com/downloads/Public/Host%20Bus%20Adapters/Host%20Bus%20Adapters%20Common%20Files/SAS_SATA_12G_P${PV}/${DISTFILE_BIN}
26 doc? ( http://www.lsi.com/downloads/Public/Host%20Bus%20Adapters/${DISTFILE_DOC} )
27 "
28
29 LICENSE_URL="http://www.lsi.com/cm/License.do?url=&prodName=&subType=Miscellaneous&locale=EN"
30
31 S="${WORKDIR}/${MY_P}"
32
33 pkg_nofetch() {
34         elog "LSI has a mandatory click-through license on thier binaries."
35         elog "Please visit $HOMEPAGE and download ${DISTFILE_BIN} from the Mangement Software section."
36         elog "After downloading, move ${MY_P} into your DISTDIR directory"
37         if use doc; then
38                 elog "Please also download 'SAS-3 Integrated RAID Configuration Utility User Guide' (${DISTFILE_DOC}) "
39                 elog "and also place it into your DISTDIR directory"
40         fi
41 }
42
43 supportedcards() {
44         elog "This binary supports should support ALL cards, including, but not"
45         elog "limited to the following series:"
46         elog ""
47         elog "LSI SAS 3004"
48         elog "LSI SAS 3008"
49 }
50
51 src_unpack() {
52         unpack ${DISTFILE_BIN}
53 }
54
55 src_install() {
56         exeinto /opt/lsi/
57         use amd64 || use x86 && doexe sas3ircu_linux_x86_rel/sas3ircu
58         use ppc64 && doexe sas3ircu_linux_x86_rel/sas3ircu
59         use amd64-fbsd && doexe sas3ircu_freebsd_amd64_rel/sas3ircu
60         use x86-fbsd && doexe sas3ircu_freebsd_i386_rel/sas3ircu
61         use x64-solaris || use x86-solaris && doexe sas3ircu_solaris_x86_rel/sas3ircu
62         use sparc-solaris && doexe sas3ircu_solaris_sparc_rel/sas3ircu
63         if use efi; then
64                 exeinto /boot/efi/
65                 doexe sas3ircu_udk_uefi__x64_rel/sas3ircu.efi
66         fi
67         dodoc IRCU_MPT_GEN3_Phase5.0-06.00.00.00.pdf
68         dodoc README_SAS3IRCU_P${PV}.txt
69         use doc && dodoc "${DISTDIR}"/$DISTFILE_DOC
70 }