Merge github#363: sys-process/atop: add systemd support
[gentoo.git] / sys-block / parted / parted-3.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit autotools eutils
8
9 DESCRIPTION="Create, destroy, resize, check, copy partitions and file systems"
10 HOMEPAGE="https://www.gnu.org/software/parted"
11 SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
16 IUSE="+debug device-mapper nls readline selinux static-libs"
17 RESTRICT="test"
18
19 # specific version for gettext needed
20 # to fix bug 85999
21 RDEPEND="
22         >=sys-fs/e2fsprogs-1.27
23         >=sys-libs/ncurses-5.7-r7:0=
24         device-mapper? ( >=sys-fs/lvm2-2.02.45 )
25         readline? ( >=sys-libs/readline-5.2:0= )
26         selinux? ( sys-libs/libselinux )
27 "
28 DEPEND="
29         ${RDEPEND}
30         nls? ( >=sys-devel/gettext-0.12.1-r2 )
31         virtual/pkgconfig
32 "
33
34 src_prepare() {
35         epatch \
36                 "${FILESDIR}"/${PN}-3.2-devmapper.patch \
37                 "${FILESDIR}"/${PN}-3.2-po4a-mandir.patch
38         eautoreconf
39 }
40
41 src_configure() {
42         econf \
43                 $(use_enable debug) \
44                 $(use_enable device-mapper) \
45                 $(use_enable nls) \
46                 $(use_enable selinux) \
47                 $(use_enable static-libs static) \
48                 $(use_with readline) \
49                 --disable-rpath \
50                 --disable-silent-rules
51 }
52
53 DOCS=( AUTHORS BUGS ChangeLog NEWS README THANKS TODO doc/{API,FAT,USER.jp} )
54
55 src_install() {
56         default
57         prune_libtool_files
58 }