dev-qt/qttest: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / sys-block / mpt-status / mpt-status-1.2.0-r1.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit toolchain-funcs
6
7 DESCRIPTION="Query tool to access the running configuration and status of LSI SCSI HBAs"
8 HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
9 SRC_URI="mirror://gentoo/${P}.tar.bz2
10         mirror://gentoo/${PN}-1.2.0-linux-sources.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 ~ppc x86"
15
16 src_prepare() {
17         default
18
19         eapply "${FILESDIR}/${PN}-1.2.0-gentoo.patch"
20
21         sed -i -e 's,\(^.*linux/compiler\.h.*$\),,' mpt-status.h || die
22         sed -i -e '/KERNEL_PATH/d' Makefile || die
23 }
24
25 src_compile() {
26         emake CC="$(tc-getCC)"
27 }
28
29 src_install() {
30         default
31         dodoc doc/{AUTHORS,Changelog,DeveloperNotes,FAQ,README,ReleaseNotes,THANKS,TODO}
32 }