dev-qt/qtx11extras: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / sys-block / libzbc / libzbc-5.5.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools
7
8 DESCRIPTION="A library and tools for working with ZBC and ZAC disks"
9 HOMEPAGE="https://github.com/hgst/libzbc"
10 SRC_URI="https://github.com/hgst/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="BSD-2 GPL-3 LGPL-3"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="gtk"
16
17 DEPEND="virtual/pkgconfig
18         >=sys-kernel/linux-headers-4.13
19         gtk? ( x11-libs/gtk+:3 )"
20
21 PATCHES=(
22         "${FILESDIR}/libzbc-no-automagic-gtk-dep.patch"
23 )
24
25 src_prepare() {
26         default
27         eautoreconf
28 }
29
30 src_configure() {
31         econf $(use_with gtk gtk3)
32 }