sys-block/f3: drop old
[gentoo.git] / sys-block / io-scheduler-udev-rules / io-scheduler-udev-rules-1.ebuild
1 # Copyright 2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit udev
6
7 DESCRIPTION="Udev rules to allow easier customization of kernel I/O schedulers"
8 HOMEPAGE="https://gitlab.com/pachoramos/io-scheduler-udev-rules"
9 SRC_URI="https://gitlab.com/pachoramos/${PN}/-/archive/${PV}/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="amd64 x86"
14 IUSE=""
15
16 DEPEND=""
17 RDEPEND="virtual/udev"
18 BDEPEND=""
19
20 src_install() {
21         insinto /etc/default
22         doins etc/default/io-scheduler
23         udev_dorules udev/rules.d/60-io-scheduler.rules
24         einstalldocs
25 }
26
27 pkg_postinst() {
28         udev_reload
29 }