sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / sys-block / f3 / f3-7.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="7"
5
6 inherit flag-o-matic toolchain-funcs
7
8 DESCRIPTION="Utilities to detect broken or counterfeit flash storage"
9 HOMEPAGE="http://oss.digirati.com.br/f3/ https://github.com/AltraMayor/f3"
10
11 PATCHES=(
12 )
13
14 if [[ ${PV} == "9999" ]]; then
15         EGIT_REPO_URI="https://github.com/AltraMayor/${PN}.git"
16
17         PATCHES=()
18
19         inherit git-r3
20 else
21         SRC_URI="https://github.com/AltraMayor/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
22         KEYWORDS="amd64 ~arm64 x86"
23 fi
24
25 LICENSE="GPL-3+"
26 SLOT="0"
27
28 IUSE="extra"
29
30 DEPEND="extra? (
31                 sys-block/parted
32                 virtual/udev
33         )"
34
35 RDEPEND=""
36
37 DOCS=( changelog README.rst )
38
39 src_prepare() {
40         default
41
42         sed -i \
43                 -e 's:-ggdb::' \
44                 -e 's:^PREFIX =:PREFIX ?=:' \
45                 Makefile || die
46
47         tc-export CC
48 }
49
50 src_compile() {
51         default
52
53         if use extra; then
54                 emake V=1 extra
55         fi
56 }
57
58 src_install() {
59         emake PREFIX="${ED}/usr" install
60
61         if use extra; then
62                 emake PREFIX="${ED}/usr" install-extra
63         fi
64
65         einstalldocs
66 }