Drop $Id$ per council decision in bug #611234.
[gentoo.git] / sys-block / dellmgr / dellmgr-5.32-r1.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 inherit multilib rpm
5
6 MY_PV=${PV}-0
7 DESCRIPTION="Dell PERC 2/3/4 RAID controller management tool"
8 HOMEPAGE="http://linux.dell.com/"
9 SRC_URI="http://ftp.us.dell.com/scsi-raid/perc-apps-A08.tar.gz"
10
11 LICENSE="Dell"
12 SLOT="0"
13 # This package can never enter stable, it can't be mirrored and upstream
14 # can remove the distfiles from their mirror anytime.
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 RESTRICT="strip mirror test"
19
20 S="${WORKDIR}"
21
22 pkg_setup() {
23         use amd64 && { has_multilib_profile || die "needs multilib profile on amd64"; }
24 }
25
26 src_unpack() {
27         unpack ${A}
28         rpm_unpack "${S}"/Dellmgr-${MY_PV}.i386.rpm || die "failed to unpack RPM"
29 }
30
31 src_compile() {
32         echo "Nothing to compile."
33 }
34
35 src_install() {
36         newsbin "${FILESDIR}"/dellmgr-r2 dellmgr
37         dosbin usr/sbin/dellmgr.bin
38 }