dev-python/csv23: keyworded 0.3.2 for ia64, bug #719700
[gentoo.git] / sys-auth / ykpers / ykpers-1.19.3-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools udev
7
8 DESCRIPTION="Library and tool for personalization of Yubico's YubiKey"
9 SRC_URI="https://github.com/Yubico/yubikey-personalization/archive/v${PV}.tar.gz -> ${P}.tar.gz"
10 HOMEPAGE="https://github.com/Yubico/yubikey-personalization"
11
12 KEYWORDS="amd64 x86"
13 SLOT="0"
14 LICENSE="BSD-2"
15 IUSE="consolekit static-libs"
16
17 DEPEND="
18         dev-libs/json-c:=
19         >=sys-auth/libyubikey-1.6
20         virtual/libusb:1"
21 BDEPEND="
22         app-text/asciidoc
23         virtual/pkgconfig"
24 RDEPEND="${DEPEND}
25         consolekit? ( sys-auth/consolekit[acl] )
26 "
27
28 S="${WORKDIR}/yubikey-personalization-${PV}"
29
30 DOCS=( doc/. AUTHORS NEWS README )
31
32 src_prepare() {
33         default
34         eautoreconf
35 }
36
37 src_configure() {
38         local myeconfargs=(
39                 --libdir=/usr/$(get_libdir)
40                 --localstatedir=/var
41                 $(use_enable static-libs static)
42         )
43         econf "${myeconfargs[@]}"
44 }
45
46 src_install() {
47         default
48
49         udev_dorules 69-yubikey.rules
50         if use consolekit ; then
51                 udev_dorules 70-yubikey.rules
52         fi
53
54         find "${D}" -name '*.la' -delete || die
55 }