sys-auth/elogind: ppc stable wrt bug #711230
[gentoo.git] / sys-auth / pam_u2f / pam_u2f-1.0.6.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools flag-o-matic pam
7
8 DESCRIPTION="Library for authenticating against PAM with a Yubikey"
9 HOMEPAGE="https://github.com/Yubico/pam-u2f"
10 SRC_URI="https://developers.yubico.com/${PN/_/-}/Releases/${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="debug"
16
17 RDEPEND="
18         app-crypt/libu2f-host
19         app-crypt/libu2f-server:=
20         sys-libs/pam"
21
22 DEPEND="${RDEPEND}
23         virtual/pkgconfig"
24
25 PATCHES=( "${FILESDIR}/${PN}-1.0.2-fix-Makefile.patch" )
26
27 src_prepare() {
28         default
29         use debug || append-cppflags -UDEBUG_PAM -UPAM_DEBUG
30         eautoreconf
31 }
32
33 src_configure() {
34         econf --with-pam-dir=$(getpam_mod_dir)
35 }