sys-power/apcupsd: Fixup missing || die
[gentoo.git] / sys-auth / pam_passwdqc / pam_passwdqc-1.0.5.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 inherit pam eutils toolchain-funcs
6
7 DESCRIPTION="Password strength checking for PAM aware password changing programs"
8 HOMEPAGE="http://www.openwall.com/passwdqc/"
9 SRC_URI="http://www.openwall.com/pam/modules/pam_passwdqc/${P}.tar.gz"
10
11 LICENSE="Openwall BSD public-domain"
12 SLOT="0"
13 KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
14
15 DEPEND="virtual/pam"
16 RDEPEND="${DEPEND}"
17
18 src_unpack() {
19         unpack ${A}
20
21         cd "${S}"
22         epatch "${FILESDIR}/${P}-makefile.patch"
23 }
24
25 src_compile() {
26         emake \
27                 OPTCFLAGS="${CFLAGS}" \
28                 CC="$(tc-getCC)" \
29                 LD="$(tc-getCC)" \
30                 || die "emake failed"
31 }
32
33 src_install() {
34         dopammod pam_passwdqc.so
35
36         doman pam_passwdqc.8
37         dodoc README PLATFORMS INTERNALS
38 }
39
40 pkg_postinst() {
41         elog
42         elog "To activate pam_passwdqc use pam_passwdqc.so instead"
43         elog "of pam_cracklib.so in /etc/pam.d/system-auth."
44         elog "Also, if you want to change the parameters, read up"
45         elog "on the pam_passwdqc(8) man page."
46         elog
47 }