c8cf69e83392e1de14372aa73627c44a300fbb3d
[gentoo.git] / sys-auth / pam_bioapi / pam_bioapi-0.4.0-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=0
5
6 inherit eutils
7
8 DESCRIPTION="PAM interface to bioapi package"
9 HOMEPAGE="https://code.google.com/p/pam-bioapi/"
10 SRC_URI="https://pam-bioapi.googlecode.com/files/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="x86"
15 IUSE=""
16
17 DEPEND="sys-auth/bioapi
18         sys-libs/pam
19         dev-db/sqlite"
20 RDEPEND="${DEPEND}
21         sys-auth/tfm-fingerprint"
22
23 src_unpack() {
24         unpack ${A}
25         cd "${S}"
26         epatch "${FILESDIR}"/${P}-headers.patch #241322
27         sed -i \
28                 -e 's/-version-info 0:4:0/-avoid-version/' \
29                 libpam_bioapi/Makefile.in #261598
30         sed -i \
31                 -e 's:@prefix@::' \
32                 -e '/pam_unix.so/s:.*:auth include system-auth:' \
33                 etc/pam.d/{bioapi_chbird,test-pam_bioapi}.in #261598
34 }
35
36 src_compile() {
37         econf --sbindir=/sbin || die
38         emake || die
39 }
40
41 src_install() {
42         emake install DESTDIR="${D}" || die
43         dodoc AUTHORS ChangeLog NEWS README TODO
44
45         dodir /$(get_libdir)
46         mv "${D}"/usr/$(get_libdir)/security "${D}"/$(get_libdir)/ || die
47         rm -f "${D}"/$(get_libdir)/security/*.la
48 }