net-misc/quagga: revision bump
[gentoo.git] / sys-auth / nss-myhostname / nss-myhostname-0.3.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="4"
5
6 DESCRIPTION="Name Service Switch module for resolving the local hostname"
7 HOMEPAGE="http://0pointer.de/lennart/projects/nss-myhostname/"
8 SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
9
10 LICENSE="LGPL-2.1+"
11 SLOT="0"
12 KEYWORDS="alpha amd64 arm ~arm64 ia64 ppc ppc64 sparc x86"
13 IUSE=""
14
15 COMMON_DEPEND=""
16 RDEPEND="${COMMON_DEPEND}
17         !>=sys-apps/systemd-197"
18 DEPEND="${COMMON_DEPEND}"
19
20 src_prepare() {
21         # The documentation in doc/ is just the README file in other formats
22         sed -e 's:SUBDIRS *= *doc:SUBDIRS =:' -i Makefile.{am,in} ||
23                 die "sed failed"
24 }
25
26 src_configure() {
27         econf --disable-lynx
28 }
29
30 pkg_postinst() {
31         elog "You must modify your name service switch lookup file to enable"
32         elog "nss-myhostname. To do so, add 'myhostname' to the hosts line in"
33         elog "/etc/nsswitch.conf"
34         elog
35         elog "An example hosts line looks like this:"
36         elog "hosts:      files dns myhostname"
37         elog
38 }