sys-auth/elogind: amd64 stable wrt bug #716826
[gentoo.git] / sys-auth / libnss-pgsql / libnss-pgsql-1.5.0_beta-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools
7
8 KEYWORDS="~amd64 ~x86"
9
10 DESCRIPTION="Name Service Switch module for use with PostgreSQL"
11 HOMEPAGE="http://pgfoundry.org/projects/sysauth/"
12
13 MY_P="${P/_/-}"
14 SRC_URI="http://pgfoundry.org/frs/download.php/1878/${MY_P}.tgz"
15 S="${WORKDIR}/${MY_P}"
16
17 LICENSE="GPL-2"
18 SLOT="0"
19 IUSE=""
20
21 RDEPEND="dev-db/postgresql:*"
22 DEPEND="${RDEPEND}
23                 app-text/xmlto"
24
25 src_prepare() {
26         eapply "${FILESDIR}/${P}-gentoo.patch"
27         eapply_user
28         eautoreconf
29 }
30
31 src_install() {
32         emake DESTDIR="${D}" install
33         find "${D}" -name '*.la' -delete || die
34
35         dodoc AUTHORS ChangeLog NEWS README
36         docinto examples
37         dodoc conf/*
38 }
39
40 pkg_postinst() {
41         elog "Next steps:"
42         elog "1. Create the required tables in the database:"
43         elog "   $ psql a_database -f /usr/share/doc/${PF}/examples/dbschema.sql"
44         elog "2. Create the configuration file '/etc/nss-pgsql.conf'"
45         elog "   You can copy the example from /usr/share/doc/${PF}/examples/nss-pgsql.conf"
46         elog "3. Edit /etc/nsswitch.conf to use the NSS service 'pgsql'"
47         elog "   An example is available here: /usr/share/doc/${PF}/examples/nsswitch.conf"
48 }