dev-qt/qtquickcontrols: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / sys-auth / libfprint / libfprint-1.90.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit meson udev
7
8 DESCRIPTION="library to add support for consumer fingerprint readers"
9 HOMEPAGE="https://cgit.freedesktop.org/libfprint/libfprint/ https://github.com/freedesktop/libfprint https://gitlab.freedesktop.org/libfprint/libfprint"
10 SRC_URI="https://gitlab.freedesktop.org/libfprint/libfprint/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
15 IUSE="examples"
16
17 RDEPEND="dev-libs/glib:2
18         dev-libs/nss
19         >=dev-libs/libgusb-0.3.1
20         virtual/libusb:1=
21         x11-libs/gtk+:3
22         x11-libs/pixman
23         x11-libs/libX11
24         x11-libs/libXv"
25
26 DEPEND="${RDEPEND}
27         dev-util/gtk-doc"
28
29 BDEPEND="virtual/pkgconfig"
30
31 PATCHES=( ${FILESDIR}/${PN}-0.8.2-fix-implicit-declaration.patch )
32
33 S="${WORKDIR}/${PN}-v${PV}"
34
35 src_configure() {
36                 local emesonargs=(
37                         -Ddoc=false
38                         -Dgtk-examples=$(usex examples true false)
39                         -Ddrivers=all
40                         -Dudev_rules=true
41                         -Dudev_rules_dir=$(get_udevdir)/rules.d
42                         --libdir=/usr/$(get_libdir)
43                 )
44                 meson_src_configure
45 }