sys-auth/pam_krb5: stable 4.9 for sparc, bug #715606
[gentoo.git] / sys-auth / libfprint / libfprint-0.99.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit meson udev
7
8 DESCRIPTION="library to add support for consumer fingerprint readers"
9 HOMEPAGE="https://cgit.freedesktop.org/libfprint/libfprint/ https://github.com/freedesktop/libfprint"
10 SRC_URI="https://github.com/freedesktop/libfprint/archive/V_$(ver_rs 0-3 '_').tar.gz -> ${P}.tar.gz"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm ~arm64 ~ia64 ppc ppc64 sparc x86"
15 IUSE="examples"
16
17 RDEPEND="dev-libs/glib:2
18          dev-libs/nss
19          virtual/libusb:1=
20          x11-libs/gtk+:3
21          x11-libs/pixman
22          x11-libs/libX11
23          x11-libs/libXv"
24
25 DEPEND="${RDEPEND}
26         dev-util/gtk-doc"
27
28 BDEPEND="virtual/pkgconfig"
29
30 PATCHES=( ${FILESDIR}/${PN}-0.8.2-fix-implicit-declaration.patch )
31
32 S="${WORKDIR}/${PN}-V_$(ver_rs 0-3 '_')"
33
34 src_configure() {
35                 local emesonargs=(
36                         -Ddoc=false
37                         -Dx11-examples=$(usex examples true false)
38                         -Ddrivers=all
39                         -Dudev_rules=true
40                         -Dudev_rules_dir=$(get_udevdir)/rules.d
41                         --libdir=/usr/$(get_libdir)
42                 )
43                 meson_src_configure
44 }