Use https by default
[gentoo.git] / sys-auth / libfprint / libfprint-0.5.1-r1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit autotools eutils udev vcs-snapshot
8
9 MY_PV="v_${PV//./_}"
10 DESCRIPTION="library to add support for consumer fingerprint readers"
11 HOMEPAGE="http://cgit.freedesktop.org/libfprint/libfprint/"
12 SRC_URI="http://cgit.freedesktop.org/${PN}/${PN}/snapshot/${MY_PV}.tar.bz2 -> ${P}.tar.bz2
13         https://dev.gentoo.org/~patrick/libfprint-0.5.1-add-vfs5011-driver.patch"
14
15 LICENSE="LGPL-2.1"
16 SLOT="0"
17 KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
18 IUSE="debug static-libs"
19
20 RDEPEND="virtual/libusb:1
21         dev-libs/glib:2
22         dev-libs/nss
23         || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] x11-libs/gdk-pixbuf )"
24 DEPEND="${RDEPEND}
25         virtual/pkgconfig"
26
27 src_prepare() {
28         epatch "${DISTDIR}/${P}-add-vfs5011-driver.patch" || die
29         eautoreconf
30 }
31
32 src_configure() {
33         econf \
34                 --with-drivers=all \
35                 $(use_enable debug debug-log) \
36                 $(use_enable static-libs static) \
37                 -enable-udev-rules \
38                 --with-udev-rules-dir=$(get_udevdir)/rules.d
39         # --disable-udev-rules fails https://bugs.freedesktop.org/show_bug.cgi?id=59076
40         # $(use_enable udev udev-rules) \
41 }
42
43 src_install() {
44         emake DESTDIR="${D}" install
45
46         prune_libtool_files
47
48         dodoc AUTHORS HACKING NEWS README THANKS TODO
49 }