sys-auth/elogind: amd64 stable wrt bug #716826
[gentoo.git] / sys-auth / google-authenticator-libpam-hardened / google-authenticator-libpam-hardened-9999.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 EGIT_REPO_URI="https://github.com/mgorny/google-authenticator-libpam-hardened.git"
7 inherit autotools git-r3
8
9 DESCRIPTION="PAM Module for two step verification via mobile platform"
10 HOMEPAGE="https://github.com/mgorny/google-authenticator-libpam-hardened"
11
12 LICENSE="Apache-2.0"
13 SLOT="0"
14 IUSE="+qrcode"
15
16 DEPEND="sys-auth/oath-toolkit:=
17         sys-libs/pam
18         qrcode? ( media-gfx/qrencode:= )"
19 RDEPEND="${DEPEND}
20         !sys-auth/google-authenticator"
21
22 src_prepare() {
23         default
24         eautoreconf
25 }
26
27 src_configure() {
28         local myconf=(
29                 # TODO: use getpam_mod_dir after fixing build system
30                 --libdir="/$(get_libdir)"
31
32                 $(use_enable qrcode qrencode)
33         )
34
35         econf "${myconf[@]}"
36 }
37
38 src_install() {
39         default
40         find "${D}" -name '*.la' -delete || die
41 }