sys-auth/rtkit-0.11-r2: alpha stable
[gentoo.git] / sys-auth / fprintd / fprintd-0.5.1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5
6 inherit autotools pam systemd versionator
7
8 DESCRIPTION="D-Bus service to access fingerprint readers"
9 HOMEPAGE="https://cgit.freedesktop.org/libfprint/fprintd/"
10 MY_PV="V_$(replace_all_version_separators _)"
11 SRC_URI="https://cgit.freedesktop.org/libfprint/${PN}/snapshot/${MY_PV}.tar.bz2 -> ${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
16 IUSE="doc pam static-libs"
17
18 RDEPEND="dev-libs/dbus-glib
19         dev-libs/glib:2
20         sys-auth/libfprint
21         sys-auth/polkit
22         pam? ( sys-libs/pam )"
23 DEPEND="${RDEPEND}
24         dev-util/gtk-doc
25         dev-util/gtk-doc-am
26         dev-util/intltool
27         doc? ( dev-libs/libxml2 dev-libs/libxslt )"
28
29 S=${WORKDIR}/${MY_PV}
30
31 src_prepare() {
32         eautoreconf
33 }
34
35 src_configure() {
36         econf --disable-silent-rules \
37                 $(use_enable pam) \
38                 $(use_enable static-libs static) \
39                 $(use_enable doc gtk-doc-html) \
40                 $(systemd_with_unitdir)
41 }
42
43 src_install() {
44         emake DESTDIR="${D}" install \
45                 pammoddir=$(getpam_mod_dir)
46
47         keepdir /var/lib/fprint
48
49         find "${D}" -name "*.la" -delete || die
50
51         dodoc AUTHORS NEWS README{,.transifex} TODO
52         newdoc pam/README README.pam_fprintd
53         if use doc ; then
54                 insinto /usr/share/doc/${PF}/html
55                 doins doc/{fprintd-docs,version}.xml
56                 insinto /usr/share/doc/${PF}/html/dbus
57                 doins doc/dbus/net.reactivated.Fprint.{Device,Manager}.ref.xml
58         fi
59 }
60
61 pkg_postinst() {
62         elog "Please take a look at README.pam_fprintd for integration docs."
63 }