dev-qt/qtdeclarative: stable 5.14.2-r2 for ppc, bug #719732
[gentoo.git] / sys-apps / xinetd / xinetd-2.3.15.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit flag-o-matic systemd toolchain-funcs autotools
7
8 DESCRIPTION="powerful replacement for inetd"
9 HOMEPAGE="https://github.com/xinetd-org/xinetd https://github.com/openSUSE/xinetd"
10 SRC_URI="https://github.com/openSUSE/xinetd/releases/download/${PV}/${P}.tar.xz"
11
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
15 IUSE="perl rpc selinux tcpd"
16
17 DEPEND="
18         rpc? ( net-libs/libtirpc:= )
19         selinux? ( sys-libs/libselinux )
20         tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )
21 "
22 RDEPEND="
23         ${DEPEND}
24         perl? ( dev-lang/perl )
25 "
26 DEPEND="
27         ${DEPEND}
28         virtual/pkgconfig
29 "
30
31 src_prepare() {
32         default
33         eautoreconf
34
35         sed -i \
36                 -e 's:/usr/bin/kill:/bin/kill:' \
37                 "contrib/${PN}.service" || die
38 }
39
40 src_configure() {
41         econf \
42                 $(use_with tcpd libwrap) \
43                 $(use_with selinux labeled-networking) \
44                 $(use_with rpc) \
45                 --with-loadavg
46 }
47
48 src_install() {
49         default
50
51         use perl || rm -f "${ED}"/usr/sbin/xconv.pl
52
53         newinitd "${FILESDIR}"/xinetd.rc6 xinetd
54         newconfd "${FILESDIR}"/xinetd.confd xinetd
55         systemd_dounit "contrib/${PN}.service"
56
57         newdoc contrib/xinetd.conf xinetd.conf.dist.sample
58         dodoc README.md CHANGELOG
59 }