app-editors/nano: add USE=static support
[gentoo.git] / sys-apps / tuned / tuned-2.5.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=( python2_7 )
8
9 inherit python-single-r1 systemd
10
11 DESCRIPTION="Daemon for monitoring and adaptive tuning of system devices"
12 HOMEPAGE="https://fedorahosted.org/tuned/"
13 SRC_URI="https://fedorahosted.org/releases/t/u/tuned/${P}.tar.bz2"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 COMMON_DEPEND="${PYTHON_DEPS}
21         dev-python/configobj[${PYTHON_USEDEP}]
22         dev-python/decorator[${PYTHON_USEDEP}]
23         dev-python/pyudev[${PYTHON_USEDEP}]
24 "
25 DEPEND="${COMMON_DEPEND}"
26 RDEPEND="${COMMON_DEPEND}
27         sys-power/powertop
28         dev-util/systemtap
29 "
30
31 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
32
33 src_prepare() {
34         sed -i \
35                 -e "/^UNITDIR = /s:\$(shell rpm --eval '%{_unitdir}'):$(systemd_get_unitdir):" \
36                 -e "/\$(DESTDIR)\/run\/tuned/d" \
37                 Makefile ||die
38 }
39
40 src_install() {
41         default
42         newinitd "${FILESDIR}"/tuned.initd  tuned
43
44         python_fix_shebang "${ED}"
45 }