sys-apps/fd: bump to 8.1.1
[gentoo.git] / sys-apps / sg3_utils / sg3_utils-1.44.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit multilib
7
8 DESCRIPTION="Apps for querying the sg SCSI interface"
9 HOMEPAGE="http://sg.danny.cz/sg/"
10 #SRC_URI="https://github.com/hreinecke/sg3_utils/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11 SRC_URI="http://sg.danny.cz/sg/p/${P}.tar.xz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
16 IUSE="static-libs"
17
18 DEPEND="sys-devel/libtool"
19 RDEPEND="!sys-apps/rescan-scsi-bus"
20
21 PATCHES=(
22         "${FILESDIR}"/${PN}-1.26-stdint.patch #580236
23 )
24
25 src_configure() {
26         econf $(use_enable static-libs static)
27 }
28
29 src_install() {
30         default
31         dodoc COVERAGE doc/README examples/*.txt
32         newdoc scripts/README README.scripts
33
34         # Better fix for bug 231089; some packages look for sgutils2
35         local path lib
36         path="/usr/$(get_libdir)"
37         for lib in "${ED%/}/"${path}/libsgutils2.*; do
38                 lib=${lib##*/}
39                 dosym "${lib}" "${path}/${lib/libsgutils2/libsgutils}"
40         done
41
42         find "${ED}" -name "*.la" -delete || die
43 }