sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / sys-apps / setserial / setserial-2.17-r5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Configure your serial ports with it"
9 HOMEPAGE="http://setserial.sourceforge.net/"
10 SRC_URI="
11         ftp://tsx-11.mit.edu/pub/linux/sources/sbin/${P}.tar.gz
12         ftp://ftp.sunsite.org.uk/Mirrors/tsx-11.mit.edu/pub/linux/sources/sbin/${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
17
18 PATCHES=(
19         "${FILESDIR}"/${P}-spelling.patch
20         "${FILESDIR}"/${P}-manpage-updates.patch
21         "${FILESDIR}"/${P}-headers.patch
22         "${FILESDIR}"/${P}-build.patch
23         "${FILESDIR}"/${P}-hayes-esp.patch
24         "${FILESDIR}"/${P}-darwin.patch
25 )
26
27 src_compile() {
28         tc-export CC
29         emake "${PN}"
30 }
31
32 src_install() {
33         doman "${PN}.8"
34         into /
35         dobin "${PN}"
36
37         insinto /etc
38         doins serial.conf
39         newinitd "${FILESDIR}"/serial-2.17-r4 serial
40
41         einstalldocs
42         docinto txt
43         dodoc Documentation/*
44 }