games-emulation/gfceux: remove unused patch
[gentoo.git] / sys-apps / secilc / secilc-2.7_rc4.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5 inherit toolchain-funcs
6
7 MY_P="${P//_/-}"
8 MY_RELEASEDATE="20170630"
9
10 SEPOL_VER="${PV}"
11
12 DESCRIPTION="SELinux Common Intermediate Language (CIL) Compiler"
13 HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
14
15 if [[ ${PV} == 9999 ]]; then
16         inherit git-r3
17         EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
18         S="${WORKDIR}/${MY_P}/${PN}"
19 else
20         SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
21         KEYWORDS="~amd64 ~x86"
22         S="${WORKDIR}/${MY_P}"
23 fi
24
25 LICENSE="GPL-2"
26 SLOT="0"
27 IUSE=""
28
29 DEPEND="
30         app-text/xmlto
31         >=sys-libs/libsepol-${SEPOL_VER}
32         "
33 RDEPEND="
34         >=sys-libs/libsepol-${SEPOL_VER}
35         "
36
37 # tests are not meant to be run outside of the
38 # full SELinux userland repo
39 RESTRICT="test"
40
41 src_compile() {
42         tc-export CC
43         default
44 }