Remove myself from maintainers
[gentoo.git] / sys-apps / s6-linux-init / s6-linux-init-0.3.1.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Generates an init binary for s6-based init systems"
7 HOMEPAGE="https://www.skarnet.org/software/s6-linux-init/"
8 SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
9
10 LICENSE="ISC"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="static"
14
15 DEPEND=">=sys-devel/make-3.81
16         static? (
17                 >=dev-libs/skalibs-2.6.0.0[static-libs]
18         )
19         !static? (
20                 >=dev-libs/skalibs-2.6.0.0
21         )
22 "
23 RDEPEND="
24         >=dev-lang/execline-2.3.0.2
25         >=sys-apps/s6-2.6.1.0
26         >=sys-apps/s6-linux-utils-2.4.0.0
27         >=sys-apps/s6-portable-utils-2.2.1.1
28         !static? (
29                 >=dev-libs/skalibs-2.6.0.0:=
30         )
31 "
32
33 DOCS="INSTALL examples"
34 HTML_DOCS="doc/*"
35
36 src_prepare() {
37         default
38
39         # Remove QA warning about LDFLAGS addition
40         sed -i "s/tryldflag LDFLAGS_AUTO -Wl,--hash-style=both/:/" "${S}/configure" || die
41
42         # configure overrides gentoo's -fstack-protector default
43         sed -i "/^tryflag CFLAGS_AUTO -fno-stack-protector$/d" "${S}/configure" || die
44 }
45
46 src_configure() {
47         econf \
48                 --bindir=/bin \
49                 --dynlibdir=/$(get_libdir) \
50                 --libdir=/usr/$(get_libdir)/${PN} \
51                 --with-dynlib=/$(get_libdir) \
52                 --with-lib=/usr/$(get_libdir)/skalibs \
53                 --with-sysdeps=/usr/$(get_libdir)/skalibs \
54                 $(use_enable static allstatic) \
55                 $(use_enable static static-libc)
56 }
57
58 pkg_postinst()
59 {
60         einfo "The generated init script requires additional packages."
61         einfo "Read ${ROOT}usr/share/doc/${PF}/INSTALL for details."
62 }