171342f9a170cf4bdaf8b95dd85281baa55bec9f
[gentoo.git] / sys-apps / s6 / s6-2.2.4.3.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit multilib
8
9 DESCRIPTION="skarnet.org's small and secure supervision software suite"
10 HOMEPAGE="http://www.skarnet.org/software/s6/"
11 SRC_URI="http://www.skarnet.org/software/${PN}/${P}.tar.gz"
12
13 LICENSE="ISC"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="static"
17
18 DEPEND=">=sys-devel/make-4.0
19         static? (
20                 >=dev-lang/execline-2.1.4.5[static-libs]
21                 >=dev-libs/skalibs-2.3.9.0[static-libs]
22         )
23         !static? (
24                 >=dev-lang/execline-2.1.4.5
25                 >=dev-libs/skalibs-2.3.9.0
26         )
27         "
28 RDEPEND="
29         !static? (
30                 >=dev-lang/execline-2.1.4.5
31                 >=dev-libs/skalibs-2.3.9.0
32         )
33         "
34
35 src_prepare()
36 {
37         # Remove QA warning about LDFLAGS addition
38         sed -i "s~tryldflag LDFLAGS_AUTO -Wl,--hash-style=both~:~" "${S}/configure" || die
39 }
40
41 src_configure()
42 {
43         econf \
44                 $(use_enable !static shared) \
45                 $(use_enable static allstatic) \
46                 $(use_enable static) \
47                 --bindir=/bin \
48                 --sbindir=/sbin \
49                 --dynlibdir=/$(get_libdir) \
50                 --libdir=/usr/$(get_libdir)/${PN} \
51                 --datadir=/etc \
52                 --sysdepdir=/usr/$(get_libdir)/${PN} \
53                 --with-dynlib=/$(get_libdir) \
54                 --with-sysdeps=/usr/$(get_libdir)/skalibs
55 }
56
57 src_compile()
58 {
59         emake DESTDIR="${D}"
60 }
61
62 src_install()
63 {
64         default
65         dodoc -r examples
66         dohtml -r doc/*
67 }