Remove myself from maintainers
[gentoo.git] / sys-apps / restorecond / restorecond-9999.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit toolchain-funcs
7
8 MY_RELEASEDATE="20191204"
9
10 MY_P="${P//_/-}"
11 IUSE=""
12
13 if [[ ${PV} == *9999 ]] ; then
14         inherit git-r3
15         EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
16         S="${WORKDIR}/${MY_P}/${PN}"
17 else
18         SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
19         KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
20         S="${WORKDIR}/${MY_P}"
21 fi
22
23 DESCRIPTION="Daemon to watch for creation and set default SELinux fcontexts"
24 HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
25
26 LICENSE="GPL-2"
27 SLOT="0"
28
29 DEPEND=">=sys-libs/libsepol-${PV}:=
30         >=sys-libs/libselinux-${PV}:=
31         dev-libs/dbus-glib
32         dev-libs/libpcre:=
33         >=sys-libs/libcap-1.10-r10:="
34
35 RDEPEND="${DEPEND}
36         !<sys-apps/policycoreutils-2.7_pre"
37
38 src_prepare() {
39         default
40
41         sed -i 's/-Werror//g' "${S}"/Makefile || die "Failed to remove Werror"
42 }
43
44 src_compile() {
45         tc-export CC
46         default
47 }
48
49 src_install() {
50         emake DESTDIR="${D}" install
51
52         rm -rf "${D}/etc/rc.d" || die
53
54         newinitd "${FILESDIR}/restorecond.init" restorecond
55 }